UC Insights from in CITES

Entering content area for UC Insights from in CITES

blog posts

  • Lync 2013 mobile clients (with Lync 2010 server infrastructure)

    Lync 2013 mobile client is now available for Android (minimum version 4.0), Windows 8 phones, iPhone and iPad (minimum iOS 6.0), however, they won't work with Lync 2010 server infrastructure. We are tentatively scheduled to upgrade/migrate to 2013 on the server side end of summer 2013.